Distance Learning

System Requirements

Moodle Requirements

 Use with Moodle 3.10

  • Firefox, Chrome, Safari, Microsoft Edge
  • Safari 7 and below have compatibility issues with Moodle 3.10
  • For mobile, use Safari or Chrome

For best results

  • Use the most up-to-date version of your browser.
  • Enable cookies, JavaScript, and pop-ups. (consult help)
  • Install a PDF reader, if needed.